Data Processing Delay
Incident Report for Grepsr
Resolved
The issue has been resolved successfully.
Posted Jun 12, 2021 - 00:05 UTC
Identified
Due to high system traffic, data processing and visibility may be delayed by up to 11 minutes.
Posted Jun 11, 2021 - 23:49 UTC