Data Processing Delay
Incident Report for Grepsr
Resolved
The issue has been resolved successfully.
Posted Aug 16, 2019 - 01:05 UTC
Identified
Due to high system traffic, data processing and visibility may be delayed by up to 32 minutes.
Posted Aug 16, 2019 - 00:59 UTC