Data Processing Delay
Incident Report for Grepsr
Resolved
The issue has been resolved successfully.
Posted May 15, 2020 - 11:32 UTC
Update
Due to high data traffic, data processing and visibility may be delayed by up to 43 minutes.
Posted May 15, 2020 - 11:22 UTC
Identified
Due to high system traffic, data processing and visibility may be delayed by up to 31 minutes.
Posted May 15, 2020 - 10:51 UTC